Page tree
Skip to end of metadata
Go to start of metadata

 CapaInstaller 5


This document describes software requirements for CapaInstaller 5


To install CapaInstaller, you have to be aware of the different requirements for the individual components.


 Prerequisites

CapaInstaller Agents and Setup Wizard

  • Microsoft Windows Installer 3.1
  • Microsoft .NET Framework version 2.0. 


CapaInstaller Console, CapaInstaller SDK and the Package Creator

  • Microsoft .NET Framework version 3.5

 Minimum Requirements

To install and configure CapaInstaller services a Microsoft Windows Server operating system is required. Both desktop and mobile platforms are supported as managed clients, please refer to the lists below.


Please note:

  • The CapaInstaller components below supports and are tested on the listed platforms.
  • Be aware of the additional notes related to the components in the list!


Network

 Network requirements

 Default network ports utilized by devices and services


⇒ Incoming

443 TCP ⇒ CapaInstaller MDM Service

Encrypted communication for devices

5021 TCP ⇒ CapaInstaller Front-end Service

Internal non-encrypted communication for devices

5022 TCP ⇒ CapaInstaller Front-end Service

Public encrypted communication for devices

5023 TCP ⇒ CapaInstaller Back-end Service

Encrypted communication for services

5030 TCP ⇒ CapaInstaller OS Deployment Service

Encrypted communication for services

5024 ⇒ CapaInstaller SCEP Service

Certificate exchange for devices

8443 TCP ⇒ CapaInstaller MDM Service

Encrypted communication for devices

Outgoing ⇒

443 TCP ⇒ Windows Push Notification Services

Microsoft push notifications

2195 | 2196 TCP ⇒ Apple Push Notification service

Apple push notifications

443 | 5228 | 5229 | 5230 TCP ⇒ Google Cloud Messaging

Google push notifications

7000 TCP ⇒ CapaSystems Web Services

Certificate and License Management




The referenced ports for CapaInstaller services are the default values. If the defaults are changed, refer to the port set configured for the services in your organization.

If you have other isolated zones, for example a separate WIFI zone, a DMZ or an offsite hosting zone, port for these zones should be observed to be opened accordingly.


Services

 Supported platforms

Server Operating systems

    • Windows Server 2008 R2
    • Windows Server 2012
    • Windows Server 2012 R2
    • Windows Server 2016

Client Operating Systems

    • Windows 7
    • Windows 8.1
    • Windows 10

Database Servers

    • Microsoft SQL Server 2008 R2 
    • Microsoft SQL Server 2012 (SQL authentication)
    • Microsoft SQL Server 2014 (SQL authentication)
    • Microsoft SQL Server 2016 (SQL authentication)
  • SQL Server must have the TCP/IP protocol enabled and the firewall must be opened for incoming SQL traffic. and SQL Reporting Services must be included in order to support the CapaInstaller Reporting feature.
  • When using SQL Server express it must be SQL Express with Advanced Services to support SQL Reporting
  • From version 2012 and above Windows Authentication is no longer supported for service logins. SQL logins should be used!


Desktop Management

 Supported platforms

Windows Desktop

  • Windows 7 and above


Windows Server

  • Windows Server 2008R2 and above


OS Deployment

 Supported platforms

Server

  • Windows ADK for Windows 10, version 1903
  • Windows PE add-on for the ADK

Client

  • BIOS support for PXE 2.1 is required to utilize PXE boot.
  • When using USB devices to boot OSD, make sure the machine BIOS and the USB device are compatible.
  • WinPE 2.0 requires that the client has BIOS-level support for ACPI 2.0 and that this feature is enabled during deployment.


Device Management

 Supported platforms

Apple iOS

  • iOS version 10 and above


Apple macOS

  • 10.7 and above

  •  macOS Enterprise App Requirements

     Click here to expand...

    Please verify the following requirements with the app vendor before attempting to deploy Enterprise Apps on your devices!

    • Devices must be running macOS 10.7 (El Capitan) or newer
    • The package must be signed with a certificate.
      • A package needs to be signed by the app developer, only the package needs to be signed, not the app.
    • The package must include the following files
      • PackageInfo, Bom, Payload and [TOC].xml

      • The package can also contain Scripts and RunAtStartup but these are not required


Android

  • Android version 4.4 and above
  • Samsung KNOX 2.1 and above


Windows Mobile

  • Windows Mobile 10 and above





Management Portal

 Requirements for the Management Portal

Internet Information Services (IIS) 8.5 or above
.NET 4.5.1 or above


Please Note:

  • To be able to restart computers and devices remotely, a BaseAgent is required on the computer. Older legacy agents will not recieve the restart request.


Self Service Portal

 Requirements for the Self Service portal

Internet Information Services (IIS) 8.5 or above
.NET 4.5.1 or above


Patch Management

 Requirements
  • Microsoft WSUS 3.0 SP1or SP2
  • Microsoft WSUS 4.0


Port Number

  • By default, in Windows Server 2012, WSUS 4.0 uses port 8530. However, WSUS 3.0 uses port 80, by default.
  • Microsoft has released an update for Windows Server Update Services (WSUS) 3.0 Service Pack 2 (SP2).
     
    This update lets servers that are running Windows Server Update Services (WSUS) 3.0 SP2 provide updates to computers that are running Windows 8 or Windows Server 2012. Read more and download here: http://support.microsoft.com/kb/2734608


Reporting and Queries

 Requirements
  • Microsoft Reporting Services corresponding to the installed SQL Server version


Performance Guard Agent

 Click here to expand...
  • Windows XP (SP3) and above



Please note:

  • CapaInstaller Security model requires Active Directory.
  • CapaInstaller is not supported on file systems that are case sensitive.



Read more about How to install